Author Topic: Passing Parameters to onUIEvents  (Read 1902 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Passing Parameters to onUIEvents
« on: October 05, 2017, 05:59:47 AM »
Process:
To pass parameters to onUIEvents command with the 'using' option.

In below example we will pass order number as parameter to a liquid UI function with using option which is triggered by "onUIEvents" command.
LiquidUI Code:
//////////////////////////////////SAPLSMTR_NAVIGATION.E0100.sjs//////////////////////////////////

onUIEvents['Enter']={"fcode":"/nva02","process":test_UIEvent, "using": {z_ord_no:5455}};

function test_UIEvent(param){
     onscreen 'SAPMV45A.0102' 
          set("F[Order]" , param. z_ord_no);
          enter();
     onscreen 'SAPMSDYP.0010' // to handle information pop up if encountered
          enter();
     onscreen 'SAPMV45A.4001'
          enter();
}

On click 'Enter', screen navigates to overview screen of "VA02" t-code with details of order number passed as parameter.