Author Topic: Liquid UI- Statusmessage Window  (Read 1825 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Liquid UI- Statusmessage Window
« on: October 05, 2017, 09:13:36 AM »
Purpose:
The statusmessage command is used when it is necessary to view messages relating to the status of a particular SAP session or connection.
All messages are displayed in an onscreen message box/listbox.

Syntax:
statusmessage({"title":"Title", "size":[rows, cols], "position":[startRow, startCol]});

To add messages to the created message box/listbox 'addstring' option is used.

Syntax:
statusmessage({"addstring":string/variable to display});

In below example, we will display a listbox containing four separate status messages.
LiquidUI Code:
/////////////////////// SAPLSMTR_NAVIGATION.E0100.SJS ////////////////////////

var z_msgtitle = "Sample StatusMessage Listbox";
var z_msg = "Statusmessage command example!";
var z_msg2 = "Order Type is 'OR'";
pushbutton([TOOLBAR], "Test StatMsg", {"process":z_statmsg});

function z_statmsg() { 
     onscreen 'SAPLSMTR_NAVIGATION.0100' 
          statusmessage({"title":z_msgtitle, "size":[10,60], "position":[5,10], "addstring":z_msg}); 
          statusmessage({"addstring":"Navigating to VA01!"}); 
          enter('/nva01'); 
     onscreen 'SAPMV45A.0101' 
          set("F[Order Type]", "OR"); 
          enter(); 
          statusmessage({"title":z_msgtitle, "size":[10,60], "position":[5,10], "addstring":"VA01 Overview screen!"}); 
          statusmessage({"addstring":z_msg2});
}

See attachment for more information and screenshots.