Author Topic: Demonstrating "noinput" command  (Read 2222 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
Demonstrating "noinput" command
« on: October 05, 2017, 10:55:10 AM »
Purpose:
      The "noinput" command makes the SAP screen element read-only restricting the user input. This command can be used with any SAP screen element that allows user input but cannot be used on user-defined fields.

Syntaxes:
noinput("F[field_name]"); // Makes a single inputfield read-only.
noinput("C[checkbox_name]"); //Makes a single checkbox read-only.
noinput("T[table_name]"); //Makes an entire table read-only.
noinput("[table_name,col_name]"); //Makes a specified column read-only using the column name.
noinput("[table_name,col_no]"); //Makes a specified column read-only using the column number.

Liquid UI Code:
Below code demonstrates the usage of noinput() command on ME22N transaction.
------------------------------SAPLMEGUI.E0014.sjs--------------------------
noinput("F[Currency]"); // making the inputfield "Currency" readonly
noinput("C[GR Message]"); // making the checkbox "GR Message" readonly
noinput("T[TABLE.2]"); // making the entire table readonly using the name of the second table - "TABLE.2"
noinput("[TABLE,PO Quantity]"); // making the column - "PO Quantity" readonly using column_name
noinput("[TABLE,11]");  //  making the column - "Net Price" readonly using column_no
noinput("F[Item]");  //making the dropdown - "Item" readonly