Author Topic: _list System Variables  (Read 2129 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
_list System Variables
« on: October 10, 2017, 07:20:26 AM »
_listfirstvisiblecol:
      Specifies the position value of the first column of a list screen visible to the user.
__listlastvisiblecol:
      Specifies the position value of the last column of a list screen visible to the user.
_listtotalwidth:
      Specifies the actual width of the list screen.
_listdatawidth:
      Specifies the width of the listscreen visible to the user.

LiquidUI Code:
    Below code demonstrates the usage of above system variables on VKM1 transaction.
---------------------------- RVKRED01.E0120.sjs -------------------------------
//To display the position value of the first column visible
println("------First visible col is--------" +_listfirstvisiblecol);
//To display the position value of the last column visible
println("------Last visible col is--------" +__listlastvisiblecol);
//To display the actual width of the listscreen
println("------Total width of the list screen is--------" +_listtotalwidth);
//To display the width of the listscreen visible to the user
println("------Data Width of the list screen is---------" +_listdatawidth);

See the attachments for more information