Author Topic: LiquidUI Columnsize Command  (Read 2146 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
LiquidUI Columnsize Command
« on: October 12, 2017, 11:25:37 AM »
Purpose: This command can be used to resize and also to delete/hide the Native SAP Table Columns.

Syntax:
columnsize("[table_name,column_name]", value);
(Or)
columnsize("[table_name,column_number]", value);

Note: To hide/delete the column one needs to input the value as 0.

LiquidUI Code:
Below code demonstrates the usage of  columnsize command on VA01 transaction Overview screen.
---------------------------- SAPMV45A.E4001.sjs -------------------------------
//Resizing the column
columnsize("[All items,Material]",6);
columnsize("All items,2",6);  // Resizing Column using column number

//Deleting the column by assigning value:0
columnsize("[All items,Description]",0);

Note:
When there are Multiple Columns in the SAP Table with same column Name, then use column number instead of column name.
columnsize("All items,6",0); // Using the Column Number


See attachments for more information...
« Last Edit: April 09, 2021, 04:04:37 AM by Ashfaq Ahmed »