Author Topic: Selecting Liquid UI Table rows and columns  (Read 2584 times)

Sai Siddhartha

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 47
    • View Profile
Selecting Liquid UI Table rows and columns
« on: March 01, 2018, 05:33:16 AM »
Purpose:
Selecting rows and columns in a Liquid UI table.

To select particular row in a table use following syntax.
     table_name.selectedrows[row_index] = "X";

To select particular column in a table use following syntax.
     table_name.selectedcols[col_index] = "X";

      table_name - represents name of the liquid ui table.
      row_index   - represents row number you want to select.
      col_index    - represents column number you want to select.

Liquid UI Code:
/////////////////////////////// SAPLSMTR_NAVIGATION.E0100.sjs ///////////////////////////

del("X[IMAE_CONTAIeNER]");// deletes image
table([1,1], [12,48], {"name":"proj", "title":"All items", "rows":10,"rowselection":true,"columnselection":true}); // creates table
column('Material', {"table":"T[All items]", "size":30, "name":"matnr", "position":1, "table":"T[All items]"});       
column('Quantity', {"table":"T[All items]", "size":10, "name":"qty", "position":2, "table":"T[All items]"});

// for selecting a row of a table
proj.selectedrows[0] = "X";

// for selecting a column of a table.
proj.selectedcols[1] = "X";

note: selectedrows and selectedcols are arrays there index starts from '0'