Author Topic: Using Liquid UI Pushbutton's "eventid" parameter with "_eventid" system variable  (Read 2290 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
Purpose:
To use the "eventid" parameter of push button and conditionalize the script with help of  "_eventid" system variable for displaying the event.

Pre-Requisites:
1. Liquid UI WS version 1.2.332.0 & above.
2. Liquid UI WS Server version 3.5.572.0 & above.(if accessing scripts via WS Server)

Syntax:
pushbutton([2,4], "name of button",{"eventid":"event name"});

Liquid UI Code:
Below code demonstrates the usage on SAP Easy Access Screen.
---------------------------- SAPLSMTR_NAVIGATION.E0100.sjs ----------------------
del("X[IMAGE_CONTAINER]");
pushbutton([2,4], "Order",{"eventid":"book"});
pushbutton([2,15], "Exit",{"eventid":"leave"});
if(_eventid=='book')
{
  message('You are about to confirm the order',{"title":"Confirmation","type":64});
    }
if(_eventid=='leave')
{
   message('You are about to leave the page',{"title":"Exit","type":64});
    }

See attachments for further reference...