Author Topic: LiquidUI: System Variable - _clientedition  (Read 2893 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: System Variable - _clientedition
« on: January 27, 2016, 12:23:04 PM »
Example of using the system variable "_clientedition". This systems variable can give information on what kind of device is being used to access SAP.

In this example, we display an image that depends on what kind of device you are using.

LiquidUI Code:

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////


del("X[IMAGE_CONTAINER]");

// SAP GUI Layout
if(_clientedition == undefined){
   image([0,1], "sapgui.jpg",{ "nostretch":true, "plain":true});
}
// iPhone Layout
else if(_clientedition.substring(2,3) == "F"){
   image([0,1], "iphone.jpg",{ "nostretch":true, "plain":true});
}   
// iPad Layout
else if(_clientedition.substring(2,3) == "P"){
   image([0,1], "ipad.jpg",{ "nostretch":true, "plain":true});
}
// iPod Layout
else if(_clientedition.substring(2,3) == "O"){
   image([0,1], "ipod.jpg",{ "nostretch":true, "plain":true});
}
// iPad Mini Layout
else if(_clientedition.substring(2,3) == "M"){
   image([0,1], "ipadmini.jpg",{ "nostretch":true, "plain":true});
}
// Three pushbuttons created for transaction navigation
pushbutton([10,1],"Create Sales Order","/nva01");
pushbutton([10,21],"View Sales Order","/nva02");
pushbutton([10,39],"Display Sales Order","/nva03");