Author Topic: Liquid UI: SearchHelp  (Read 2642 times)

rajesh.sabbineni

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 26
    • View Profile
Liquid UI: SearchHelp
« on: January 27, 2016, 12:24:28 PM »
Below example explains about how to display search help for liquid UI field  and additional search help options

Liquid UI Script:

del("X[IMAGE_CONTAINER]");

\\Basic Searchhelp:
inputfield ([2,4], "Sales Org.", [2,16],{"name":"z_va01_salesorg", "size":4, "searchhelp":"H_TVKO"});
inputfield ([4,4], "Mat Grp.", [4,16],{"name":"z_mm01_matgrp", "size":3, "techname":"MARA-MATKL"});

\\Restricted search help with a default value:
inputfield ([6,4], "Material", [6,16],{"name":"z_mm01_material", "size":18, "searchhelp":"MAT1", "shselname1":"WERKS", "shselvalue1":"1000"});

\\Restricted search help with dynamic value:
inputfield ([8,4], "Plant", [8,10],{"name":"z_mm01_plant", "size":4});
inputfield ([8,17], {"name":"z_mm01_material", "size":18, "searchhelp":"MAT1", "shselname1":"WERKS", "shselvalue1":"V[z_mm01_plant]","nolabel":true});

\\Retrieve description associated with the selection:
inputfield ([10,4], "Industry Sector", [10,18],{"name":"z_mm01_indsec", "size":2, "searchhelp":"H_T137","shname1":"MBBEZ", "shdest1":"V[z_mm01_inddesc]"});
inputfield ([10,23], {"name":"z_mm01_inddesc", "size":8,"nolabel":true});

See attached document for details
« Last Edit: January 27, 2016, 02:03:43 PM by rajesh.sabbineni »