Author Topic: AUTOMATED SFO SIGNATURE UPLOAD THROUGH LIQUID UI SERVER  (Read 2642 times)

Sabir Mohammad

  • Administrator
  • Newbie
  • *****
  • Posts: 52
    • View Profile
AUTOMATED SFO SIGNATURE UPLOAD THROUGH LIQUID UI SERVER
« on: March 07, 2019, 11:25:59 AM »
Purpose: To quickly upload the signature on Liquid UI Android via the Liquid UI Server with an automated pushbutton, when compared to regular SFO signature upload.

Pre-requisites:
Liquid UI WS, Liquid UI WS Server, Liquid UI Android version to 3.0.7.0 or later.

Steps:
1. Place the following WS script file "SAPLIQS0.E7200.sjs" in the local directory, as configured in guixt.sjs file of Liquid UI Server folder.

*******************************************************************
pushbutton([3,40], "@JC@Upload Signature", "/_gala_sign", {"size":[1,18]});
pushbutton([3,60], "@5M@View Signature", "?", {"size":[1,18], "process":mi04DisplayAttachment});


function mi04DisplayAttachment(){
    onscreen 'SAPLIQS0.7200'
        enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_TOOLBOX;53;102','event':2});

    onscreen 'SAPLIQS0.7200'
        enter({'control':'GOSCONTAINERCTRL.Toolbar','item':'%GOS_VIEW_ATTA','event':1});               
}

*******************************************************************

2. Run the Liquid UI Server on your machine.

3. Configure a Liquid UI Server connection on Liquid UI Android and connect.

4. Navigate to the transaction "iw24" and Select the Liquid UI pushbutton "Upload Signature".

5. Input the signature and Select "Done".

6. Make changes to the file name, if needed on the pop-up and Select "Done".

7. Your signature attachment will be successfully uploaded.                             
Select the Liquid UI pushbutton "View Signature".

8. Double tap the signature file.

9. Select the option "Yes" on the pop-up.

10. Select the appropriate option on the third party application pop-up to view the signature file.

11. You will view the signature file uploaded.


Refer to the attachments for Clarity...