Author Topic: [TROUBLESHOOT]Error when Importing from Excel  (Read 3544 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
[TROUBLESHOOT]Error when Importing from Excel
« on: June 10, 2019, 10:52:44 AM »
Symptom: Click on Liquid UI Button "Import from Excel", the following error message appears.

"CommonDialog: The common dialog function failed during initialization. This error often occurs when insufficient memory is available".

The Liquid UI Code, that is initiating the commonDialog box is provided below,

    var szPrompt = 'Openrequired File';
    var dialog = new ActiveXObject('MsComDlg.CommonDialog'); 
    dialog.Filter='All Files(*.*)|*.*'; 
    dialog.MaxFileSize=32767; 
    dialog.DialogTitle=szPrompt;
    dialog.Flags=0x200|0x80000|0x800|0x4|0x200000   // Common Dialog Flags More Flags
    dialog.ShowOpen();                                                    // Common Dialog Open Box More Methods
    var ret = dialog.FileName;
    dialog = void 0;
« Last Edit: July 09, 2019, 04:50:07 PM by Rahul Gera »