Author Topic: [TROUBLESHOOT] Scripts not being rendered with Liquid UI Server  (Read 3051 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
Purpose: To Troubleshooting steps when executing Liquid UI Server.
Issue: Modified screens not displayed when scripts are being executed from SAP Web Repository and connections are through Liquid UI Server.

Steps to STOP Liquid UI Service:
1. Windows + R, Type Services.MSC.
2. Navigate to Synactive R/3 Proxy in the list of Services.
3. Select "Synactive R/3 Proxy", and choose "STOP" service option.

GuiXT.sjs Flags, to display console log for debugging
OPENCONSOLE    =    0x00008000;
HIDECONSOLE    =    0x00000000;
TRACE_RFCCALL   =    0x10000000;

// TRACEFLAGS = HIDECONSOLE;
TRACEFLAGS = OPENCONSOLE;
// TRACEFLAGS = OPENCONSOLE|TRACE_RFCCALL;

Steps to open Liquid UI Server in Console Mode
Method 1: Using Batch File
Navigate to Liquid UI Server installed folder, and execute "ConsoleMode.bat" file.

Method 2: Using command prompt
Step 1: Windows + R, type "cmd" and hit "Enter"
Step 2: In command prompt, navigate to Liquid UI Server installed folder.
Step 3: Once in the desired folder in command prompt, type SAPPROXY.exe -debug
Step 4: The command prompt window, will be used as a Debug window.

Files needed to Read Liquid UI Scripts from SAP Web Repository
LibRFC32.dll in Liquid UI Server folder, when Liquid UI Server is executed in console mode.
LibRFC32.dll in,
32Bit O.S --> C:\Windows\System32
64Bit O.S --> C:\Windows\System32
64Bit O.S --> 32Bit Liquid UI Server Software --> C:\Windows\SysWOW64
« Last Edit: July 09, 2019, 03:40:39 PM by Rahul Gera »