Author Topic: LiquidUI:Dropdownlist  (Read 2586 times)

rajesh.sabbineni

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 26
    • View Profile
LiquidUI:Dropdownlist
« on: January 27, 2016, 04:59:10 PM »
dropdownlist command (also called combobox) creates or modifies dropdown lists on SAP screens. Below example explains on how to restrict dropdownlist values and execute a function automatically when a value is selected from the dropdownlist

LiquidUI Code:

// Sample User Interface in MM01 transaction
set("V[mylist]", "=--- Select Industry Type ---;B=Beverage;C=Chemical Industry;M=Mechanical Engineering;");
dropdownlist([10, 0], "mylist", {"refer":"F[Industry sector]", "width":30,"process":test_dropdown});


// Sample Function
function test_dropdown(){
   set("F[Industry sector]", z_ordertypeselected);
   set("F[Material Type]", "FERT");
   enter();
}

See attached document for details