Author Topic: How to define Liquid UI scripts directories for SAP customization?  (Read 3394 times)

sarvani.kusuri@guixt.com

  • Administrator
  • Newbie
  • *****
  • Posts: 3
    • View Profile
For the successful implementation of Liquid UI on your SAP GUI, you need to add all the required parameters in the configuration file (guixt.sjs) and then save it. This file is generally present in your SAPgui folder (C:\Program Files (x86)\SAP\FrontEnd\SAPgui). You need to add your scripts directory path in your guixt.sjs file for executing Liquid UI scripts.

Defining a directory path in the configuration file helps SAP GUI to find the location of script files used for customizing the SAP screens. SAP screens are customized as per the WS script added in the screen script file.

In the guixt.sjs file, you can define various Liquid UI parameters to work on the WS scripts. You can specify a maximum of four script directory paths in the configuration file, and the Liquid UI will consider the script directory in the sequential order. The script directory paths can be either local, network, HTTP, FTP, or SAP web repository.

Script directories:
Here you can see how to define the directory path of scripts.

Local directory:
Code: [Select]
directory1= "C:\\LiquidUI\\scripts";
Network directory:
Code: [Select]
directory2 = "\\\\server\\directoryName";
Web directory:
Code: [Select]
directory3 = "http://server//directoryName";
FTP directory:
Code: [Select]
directory4 = "ftp://server//directoryName";
SAP Web Repository:
Code: [Select]
directory4 = "sapwr:z.LiquidUI.demo";


« Last Edit: October 12, 2020, 08:06:42 PM by sarvani.kusuri@guixt.com »