Author Topic: Usage of Leadingspace option  (Read 2697 times)

Ashfaq Ahmed

  • Administrator
  • Newbie
  • *****
  • Posts: 29
    • View Profile
Usage of Leadingspace option
« on: October 21, 2019, 09:54:50 PM »
Purpose:

Leadingspace option retains any spaces that may exist before the character entered in an inputfield.

Syntax:

"leadingspace": true

Example:

The following are the steps that Illustrate the Implementation of the leadingspace option.

Steps:

1.Open the Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
 And add the following code snippet to the file

 Inputfield ([4,1], "Inputfield Test", [4,8], {"name": "Inputfld"," size":26});

2. Save the File and refresh the SAP screen.
3.Enter the text  "    Testing" into the inputfield.   (using spaces in-front of the Text)
4. You can see that it would not retain any spaces.
5.Now Add leadingspace option as shown below.

   inputfield([4,5], "Inputfield Test", [4,20], {"name":"Inputfld", "size":26,"leadingspace":true});

6. Save the File and refresh the SAP screen.
7.Now You can see that it retains the spaces.

Refer to the attachments for Clarity...
« Last Edit: October 22, 2019, 11:36:32 AM by Rahul Gera »