Author Topic: Server Certificate and Private Key for Liquid UI using OPENSSL  (Read 4460 times)

Rahul Gera

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 88
    • View Profile
Server Certificate and Private Key for Liquid UI using OPENSSL
« on: October 24, 2019, 11:07:31 AM »
Purpose: Creating Server certificate and Private Key using OPENSSL for Liquid UI.

Certificate can be generated with the online openssl.exe tool, with the following commands:

>>openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout private.key -out server.crt

Note: -days means the valid days for this certificate.

You are about to be asked to enter information that will be incorporated into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.

Country Name (2 letter code) [AU]:US
State or Province Name (full name) [Some-State]:CA
Locality Name (eg, city) []:
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Liquid UI WebServer
Organizational Unit Name (eg, section) []:LUS
Common Name (e.g. server FQDN or YOUR name) []:
Email Address []:

Server CRT and Private KEY are generated !!
« Last Edit: October 24, 2019, 11:09:25 AM by Rahul Gera »