Author Topic: Implementing Restrict F4 List Using IN Place Edit, Liquid UI Designer.  (Read 2639 times)

Ashfaq Ahmed

  • Administrator
  • Newbie
  • *****
  • Posts: 29
    • View Profile
Purpose:

Restrict F4 List for input fields provides a Restrict list of available entry values for a given input field.

 
Prerequisites:


  • LUI Designer.

    In Place Edit.


NOTE :

Files which are necessary for Inplace Edit to work are mentioned Below.

•   "WSCitation.dll".

•   "WSEditor.dll".

These two files should be placed into the "SapGui" Folder, (I.e.) the path "C:\Program Files (x86) \SAP\FrontEnd\SapGui".



 Using IN Place Edit

The following are the steps that will show the implementation of Restrict F4 List.


  • 1.   Open the SAP EASY Screen and click on the "Liquid UI" Button which can be seen on the top right corner of your SAP screen.

  • 2.   Create an input field by right clicking on the screen, and on the "Create New Element" pop-up. click the inputfield button as shown.

    • 3.   Create another field, double click on it and Fill up the Properties as shown.


    • 3.    Repeat the same steps by creating three more input fields.
               
              "Distr Chnl" , "Division" and "Sales Office".

    • 5.    After creating the four input fields.

    • 6.    Enter "Sales Org", as "1000" and for the "Distr Chnl" field click on the "searchhelp option" or hit F4 key.
             
             It will Restrict the values and Displays only the "Distr Chnl"values that are associated or comes under the Sales Org "1000".

    • 7.   Enter "Sales Org" as "1000", "Distr Chnl" as "10" and for the "Division" click on the "searchhelp option" or hit F4 key.
             
              It will Restrict the value and Displays only the Divisions that are associated or comes under the Sales Org "1000", Distr Chnl "10".

    • 8.   Enter "Sales Org" as "1000", "Distr Chnl" as "10", "Division"s as "00" and for the Sales Office click on the "searchhelp option" or hit F4 key.
             
              It will Restrict the values and Displays Only Sales Office that are associated or comes under the Sales Org "1000", Distr Chnl "10", Division "00".


    Using LUI Designer.

    Following are the steps that shows the implementation of Restrict F4 List.

    1.  Launch the LUI Designer and Open the SAP Easy Access Screen. (SAPLSMTR_NAVIGATOR.E0100.sjs)

    2.  Create Text, by clicking on the Button as shown.

    3.  Right Click and select the Properties option.

    4.  Name as Sales Org, click Apply and then Ok.

    5.  Create the Input Field by clicking on the Button as Shown.

    6.  Right Click and select the Properties Option.

    7.  Click on the Search Help Tab and Fill Up the Properties as Shown.

    8.  Click Apply and then click on the parameters tab.

    9.  Specify the name of the variable and Click Ok.

    10.  Repeat The same steps by creating three more input fields.
     
           "Distr Chnl", "Division" and "Sales Office".

    11.  Enter  "Sales Org" as "1000", and for the "Dist. Chnl" field click on the "searchhelp button" or hit F4 key.
           
           It will Restrict the values and Displays only the "Distr.Chnl"   values that are associated or comes under the "Sales Org" "1000".

    12.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10" and for the "Division"    click on the "searchhelp button" or hit F4 key.
           
            It will Restrict the value and Displays only the "Divisions"    that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10".

    13.  Enter "Sales Org" as "1000", "Distr.Chnl"    as "10", "Division"    as "00" and for the Sales Office click on the "searchhelp button" or hit F4 key.
           
            It will Restrict the values and Displays Only Sales Office that are associated or comes under the "Sales Org" "1000", "Distr.Chnl"    "10", "Division" "00".


    Refer to the Attachments for Clarity......