Author Topic: Start Option  (Read 2888 times)

Ashfaq Ahmed

  • Administrator
  • Newbie
  • *****
  • Posts: 29
    • View Profile
Start Option
« on: December 04, 2019, 04:22:19 AM »
Purpose:

  • Start Option is used to launch a website or an Application when an image is clicked.

  • With the help of start option we can also run (.bat and .exe Files).

The Possible Syntaxes is as Follows:

For Launching Website:

{"Start:"https://www.guixt.com/"};

For Launching an Application :

{"Start:"C://Directory_Name//Filename"};

Example I:

Following are the Steps that Illustrate the use of Start option to Launch a website.

  • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
         And add the following code snippet to the file

       image( [1,12], "C:\\LiquidUI\\scripts\\Image.png",{"start":"https://www.guixt.com"});

  • 2. Save the file and Refresh the SAP Screen.

  • 3. Click on the Image a new window will pop up that Launch the website.

Example II :

Following are the Steps that Illustrate the use of Start option to Launch an Application.

  • 1. Open the SAP Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the "guixt.sjs" file.
         And add the following code snippet to the file

      image("[TOOLBAR]", "C:\\LiquidUI\\scripts\\Designer.png",{ "start":"C:\\LiquidUI\\scripts\\Designer.exe"});

  • 2. Save the file and Refresh the SAP Screen.

  • 3. The Image is Visible on the TOOLBAR as we positioned it to be on the "TOOLBAR".

  • 4. Click on the Image which can be seen on the top right corner of your SAP Screen.

  • 5. It will Launch the Application.


Refer to the attachments for Clarity...