Author Topic: Navigation to a transaction using scanning functionality on Liquid UI Client.  (Read 2638 times)

Saisree Paluri

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 9
    • View Profile
Purpose:  Navigate to Desired transaction on click of a pushbutton with scanning functionality.

Pre-requisites:
1.Liquid UI Server Configuration,
2. Liquid UI Android version 3.0.7.0 or later.
3. Liquid UI sample Script (Script is attached to this article).


****************************************************************************************
SAMPLE WORKING SCRIPT:
The sample script is on the SAP Easy Access screen (SAPLSMTR_NAVIGATION.E0100.sjs).

del("X[IMAGE_CONTAINER]");
inputfield([1,0],"Test field",[2,0],{"name":"z_stdBrcd","size":37});
pushbutton([3,20], "@5M@Scan Barcode", "/_gala_scan,MM01,z_stdBrcd", {"size":[1,14]});

/gala_scan - Used to get the Scanner to open.
MM01 - the transaction to the user to navigate.
z_stdbrcd - the variable to the Input field.


****************************************************************************************
Example:
1. Launch Liquid UI Client App.
2. Utilize the Connection of your Liquid UI Server connection created to SAP server.
3. SAP Easy Access will appear, with Liquid UI pushbutton "SCAN BARCODE" and an input field "Test field".
4. Click on the "SCAN BARCODE" push button, the device's camera will open to scan the QR code/Barcode.
5. Scan the code, after a successful scan, the user will be navigated to the transaction as per the desired transaction given below.
              pushbutton ([3,20], "@5M@Scan Barcode", "/_gala_scan, MM01, z_stdBrcd", {"size": [1,14]});

Result:
1.User is navigated to MM01 initial screen.
2.The scanned value will be populated into the variable in the SAP Easy Access screen.




Refer to the attachment for further reference....