Author Topic: LiquidUI: File Handling  (Read 2319 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: File Handling
« on: February 02, 2016, 01:51:26 PM »
This is a basic example of opening a file, appending to it, and then closing the file. In this example we use a .txt file however you can use .csv and .xls as well.

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// Open the file up
openfile("filenames.txt", {"delimiter":";", "output":true});
name1 = "John";
name2 = "Nancy";
name3 = "Alexander";
// Append to the file, set the variables you want to carry over as true
appendfile("filenames.txt", {"name1":true, "name2":true, "name3":true});
// Always close the file after
closefile("filenames.txt");

See attached documents..