Author Topic: Creating Pushbuttons inside the Liquid UI Table Column  (Read 1500 times)

Ashfaq Ahmed

  • Administrator
  • Newbie
  • *****
  • Posts: 29
    • View Profile
Creating Pushbuttons inside the Liquid UI Table Column
« on: June 22, 2021, 11:27:19 PM »
Purpose: Below Article would help in creating pushbutton inside the Liquid UI Table using Liquid UI WS.

Pre-requisites:
Liquid UI WS

Example:

Following are the steps that needs to be followed:

Step-1:Open the Easy Access Script file "SAPLSMTR_NAVIGATION.E0100.sjs" which can be found in the directory folder as Configured in the ?guixt.sjs? file.
Create the file if it doesn't exists.

Step-2: Add the below code snippet and save it.

//Liquid UI Code:
del("X[IMAGE_CONTAINER]");
table([1,1], [10,20], {"name":"z_luitable", "title":"LIQUID UI TABLE", "rows":10});  // Liquid UI Table Generation
column('Status',{"table":"z_luitable", "name":"doc_push", "position":2, "size":10, "label":"", "pushbutton":true,"fcode":"?","process":Test});

Step-3: Refresh the SAP GUI Screen.


Refer to the Attachment for clarity....