Author Topic: LiquidUI: Creating a Process for IW21  (Read 2216 times)

chirag.amin@guixt.com

  • GuiXT Forum
  • Newbie
  • *
  • Posts: 34
    • View Profile
LiquidUI: Creating a Process for IW21
« on: February 04, 2016, 11:00:51 AM »
With LiquidUI, we can perform an SAP process through a single button by creating our own process.

LiquidUI Code:

//////////////////////////////////////////////////////////////////////////////////////////////////////////////
// Author: Synactive, Inc. [1065 E. Hillsdale Blvd, Foster City, CA, 94404, USA]
// Email: support@guixt.com; sales@guixt.com;
// Contact: 650.341.3310
// Version: 1.0.0.0
//////////////////////////////////////////////////////////////////////////////////////////////////////////////

// Have the process run with a click of a button!
pushbutton([TOOLBAR], "Create Test M1 Notification", {"process":iw21CreateNotif});

function iw21CreateNotif(){
      println("in this function");
      // Enter M1 as Notification Type
      set("F[Notification type]", "M1");
      enter();
   // this is the second screen of IW21
   onscreen 'SAPLIQS0.7200'
      // this field is for the notification description
      set("F[VIQMEL-QMTXT]", "test");
      set("F[Functional loc.]", "21-B02");
      set("F[Equipment]", "TEQ-21");
      // "/11" is the Save command
      enter('/11');
}


See attachments..