Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Sai Siddhartha

Pages: 1 2 3 [4]
46
Purpose: 
Table rows selection is not recorded by the script recorder, code needs to be added manually to perform the table row selection with function.

Syntax:-
set("cell[Tablename,columnnumber,rownumber]","X");

Eg: selection of rows from "Select view(s)" screen of "MM01" transaction.

-> Start recording on designer, on "Create Material (Initial Screen)"
     Place "Industry Sector" as "Mechanical Engineering" ,  "Material Type" as "Finished product" and click on "Select View(s)" button from Toolbar.
-> On "Select View(s)" screen, select  views  "Basic Data 1", "Basic Data 2", "Sales: Sales Org. Data 1","MRP 1", "MRP 2" and "MRP 3" and click on green tick
     mark(continue)
-> You can see pop up "Organizational Levels"
-> Now stop the recording on Liquid UI Designer

 Designer Screen shows that no code was generated between onscreen 'SAPLMGMM.0070' and enter();

To make the function complete, following script needs to be added between "SAPLMGMM.0070" and enter();
  set("cell[Table,0,1]","X");  // selecting Basic Data 1
  set("cell[Table,0,2]","X");  // selecting Basic Data 2
  set("cell[Table,0,4]","X");  // selecting Sales: Sales Org. Data 1
  set("cell[Table,0,12]","X");  // selecting MRP 1
  set("cell[Table,0,13]","X"); // selecting MRP 2
  set("cell[Table,0,14]","X");  // selecting MRP 3


See attachments for more information





47
Developer Toolkit (Designer and Workbench) / Registering PntCtl.dll
« on: June 08, 2017, 05:40:33 AM »
PntCtl.dll is an important file installed along with Designer which needs to be registered in the machine. In cases such as updating Designer and installing Designer without admin rights may lead to issues with registration of PntCtl.dll on machine which may lead to multiple issues while using designer may also lead to application crash.

below mentioned are the steps for registering PntCtl.dll on machine.

Registering PntCtl.dll

To Register PntCtl.dll on Machine follow below guidelines.
1.   Placed the File PntCtl.dll in location c:\Windows\sysWOW64\
2.   Open Command Prompt  as Administrator.
3.   Enter cd c:\Windows\sysWOW64\ and hit enter.
4.   Enter regsvr32 PntCtl.dll and hit on enter.
5.   A popup with a Success Message for Registering PntCtl.dll is shown.

Note:- For 32bit machine PntCtl.dll path will be c:\Windows\system32\.

Pages: 1 2 3 [4]