Liquid UI - Documentation - 22.01 Domains localvaluehelp and Assigning localvaluehelp using WS objects

22.01 Domains localvaluehelp and Assigning localvaluehelp using WS objects


Prerequisites


Purpose

This article walks through the scenarios showcasing the usage of the localvaluehelp command on domains.

 

Domain localvaluehelp

The localvaluehelp command provides users with potential input sets for Input Fields. Perform a right-click on the field to invoke a popup with possible input sets. This command will function on native SAP fields, Liquid UI fields, and table columns.

 

Note: To enable localvaluehelp, the following entries must be entered in the guixt.sjs configuration file

historyonrightbutton = true;
domains = "C:\\LiquidUI\\scripts";
 

Please walk through the following scenarios for a better understanding of using localvaluehelp on domains.

 
  1. Using domain’s localvaluehelp on Input Fields
     

    In this scenario, we are showcasing how localvaluehelp provides users with possible input sets for Input Fields. To illustrate the domain’s localvaluehelp on Liquid UI Input Fields, we have taken the SAP Easy Access screen as an example and proceeding with the following steps:

    • Delete the image container on the SAP Easy Access screen.
    • Add two Input Fields to display the possible input sets.
    • Assign Input Fields to localvaluehelp
     

    //Create this file inside your script folder dom.E.CURRENCY.txt
    //Now, add the following data to the above file and save it.

    // In the path specified in the configuration file place the file with the list of options-
    // dom.E.CURRENCY.txt
    ADP //Andoran peseta
    AED //United Arab Emirates Dirham
    AFA //Afghani
    ALL //Albanian Lek
    AMD //Armenian Dram
    ANG //West Indian Guilder
    AOK //Angolan Kwanza
    BBD //Barbados Dollar
     

    //Create this file inside your script folder dom.E.SHIPVIA.txt
    //Now, add the following data to the above file and save it.

    A1 //Truck - Van
    A2 //Truck - Flat Bed
    A3 //Truck - Rail Deck
    A4 //Truck - B-Train
    A5 //Truck - Maxi
    A6 //Truck - LTL
    A7 //Cust PickUp Van
    A8 //Cust PickUp Flat B
    R1 //Rail - 50' Box car d
    R3 //Rail - 52' High Cube
    R4 //Rail - 60' High Cube
    R5 //Rail - 60' Flat car
    R6 //Rail - 66' Flat car
     

    User Interface

    //Create this file inside your script folder for customizing the SAP Easy Access screen: SAPLSMTR_NAVIGATION.E0100.sjs
    //Now, let's start adding the Liquid UI script to the above file and save it.

     

    Customization

    1. Delete the image container on the SAP Easy Access screen using the del command.
       
      //Deletes the Image container on the screen
      del("X[IMAGE_CONTAINER]");
      
       
       
    2. Add two Input Fields with labels Currency and Ship Via to display the possible input sets after enabling the localvaluehelp on domains.
       
      //Creates an Input Field to search the domains localvaluehelp
      inputfield([1,1],"Currency",[1,15],{"name":"z_va0x_currency","size":3});
      //Assigns localvaluehelp to Currency Input Field 
      localvaluehelp("F[Currency]",{"domain":"CURRENCY"});
      //Creates an Input Field to search the domains localvaluehelp
      inputfield([2,1],"Ship Via",[2,15],{"name":"z_va0x_shipvia","size":2});
      //Assigns localvaluehelp to Ship Via Input Field 
      localvaluehelp("F[Ship Via]",{"domain":"SHIPVIA"});
       
       

    SAP Process

     
    1. Refresh the SAP Easy Access screen and right-click on the Currency Input Field to display the related possible input sets, as shown in the image below:
       
       
    2. Similarly, right-clicking on the Ship Via Input Field will display the access help for possible input sets.
       
       
  2. Assigning Localvaluehelp using a WS object
     

    Purpose

    To demonstrate how to assign localvaluehelp using a WS (Reebok) object. With this method, the domain is a property of the object, and so we will declare that property. To illustrate the creation of a WS object and assign localvaluehelp, we have taken the VA01 screen as an example and will walk you through the following steps:

    1. Create a Reebok object.
    2. Assign localvaluehelp to a Reebok object (a WS object).
     

    The basic syntax for assigning the localvaluehelp to the Reebok object is as follows:

     
    var ob = Reebok("F[Label]");
    ob.domain = " domain ";
     

    User Interface

     

    //Create the file SAPMV45A.E0101.sjs inside your script folder for customizing the Create Sales Order: (Initial Screen).
    //Now, let's add the Liquid UI script to this file and save it.

     

    Customization

    1. Create a new WS object in the VA01 script file using the following code and save it.
       
      var ob = Reebok("F[Material]");
      ob.domain = " MATR ";
      println( "this objects domain name is " + ob.domain); // Print out its domain name
      
       
       
    2. Add the following Liquid UI script to the VA01 script file and save it.
       
      //Assigns localvaluehelp to Order Type Input Field and suggests the input sets from domain MATR.
      localvaluehelp("F[Order Type]",{"domain":"MATR"});
     

    SAP Process

     
    1. Refresh the SAP screen and right-click on the input field to enable localvaluehelp and display the available entries.
       
       
       

      Parent topic: localvaluehelp


Can't find the answers you're looking for?