Liquid UI - Documentation - 23.19 RFC User Authorization and Calls

23.19 RFC User Authorization and Calls


Remote Function Call (RFC) is a standard SAP interface that is used for several functions and mainly to communicate between systems. RFC requires a valid username and password to login into the system, stored in the Liquid UI profile. The default login is the user SAPCPIC. However, in production systems, this user is locked. Therefore, we recommend creating a special Liquid UI RFC user with all rights.

Note: You can use your Liquid UI login credentials for testing purposes.


Purpose

The purpose of this documentation is to illustrate how you can set up a trusted relationship between two ERP systems. At the Liquid UI scripts level, RFC first accesses the scripts stored at the web repository and then gets data from function modules.

We will walk you through the following steps.

  1. Delete unnecessary screen elements
  2. Creating a role in the Liquid UI Server
  3. Defining the parameters to the role
  4. Specifying the function group for function modules using existing Remote Enabled SAP Function Modules
  5. Assigning the role of the RFC user
  6. Communicating between two ERP systems through RFC


User Interface

//Create this file inside your script folder for customizing the SAP Easy Access screen: SAPLSMTR_NAVIGATION.E0100.sjs
//Now, let's start adding the Liquid UI script to the above file.

  1. Logon to SAP and delete the unnecessary elements on the SAP Easy Access screen.
     
    //Deletes all the screen elements on the SAP Easy Access screen 
    del();
    
     
     

Let’s dive into the process of creating a Role in Liquid UI.

Follow the below steps to create an RFC user using SU01 and SU02 transactions in SAP. Let’s proceed with an example that illustrates “how to create the necessary user rights for web repository access”. Consider two systems Liquid UI Server & SAP ERP systems, where Liquid UI Server is the source, and SAP ERP is the destination. Here, we are trying to get user details from a function module called BAPI.


Creating the RFC in Liquid UI Server (source)
  1. Logon to SAP, and navigate to the SU02 transaction.
     
     
  2. Click on the To Profile Generator pushbutton on the SAP initial screen.
     
     
  3. Enter the Role name, and click on the Single Role pushbutton. Here, we are mentioning the role name as 'LIQUIDUIDSERVER'.
     
     
  4. Click on the tab Authorizations. In the appeared pop-up, click Yes, as shown below.
     
     
  5. In the appeared screen, click Change Authorization Data.
     
     
  6. Then a screen appears with a list of templates, click Do not select templates, located at the bottom.
     
     
  7. Now, click on the icon Manually, located on the menu bar, as shown below.
     
     
  8. In the appeared pop-up, enter authorization objects S_RFC, S_USER_GRP and S_USER_SYS, as shown below; click Enter.
     
     
  9. On the appeared screen, click Open.
     
     
  10. Click on the change icon (highlighted), as shown in the following image.
     
     
  11. In the appeared pop-up, check the Execute checkbox; click Enter.
     
     
  12. Repeat the same process for Name (Whitelist) of RFC object, and Type of RFC object.
     
     
  13. Now, select the parameters for “name (whitelist) of RFC object” as RFC1, SDIFRUNTIME, SYST, SURL, SU_USER, and then click enter.
     
     
  14. Now, specify the function group for those function modules using existing Remote Enabled SAP Function Modules. Then, set the type of RFC object to switch access. Also check the FUGR function group, as shown in the below image.
     
     
  15. With this, defining parameters is completed, and appears on the screen, as shown below.
     
     
  16. Click the Generate button on the toolbar, as shown in the following image.
     
     
  17. On the appeared pop-up, hit enter.
     
     
  18. Click Save on the appeared screen, as shown below.
     
     
  19. Now, click the back button, which navigates to the following screen.
     
     
  20. In the appeared pop-up, click Generate icon.
     
     
  21. Then a screen appears with the created profile, as shown in the following image.
     
     

With this profile creation comes to end. Now, we have to assign this role (LiquidUISERVER) to the RFC user.

Assigning the Role LIQUIDUISERVER to the RFCSource.

Follow the below steps to assign the role LIQUIDUIDSERVER to the user (RFCSource).

  1. Navigate to the SU01 transaction, and enter the user as RFCSource; click Create.
     
     
  2. In the appeared screen, enter the Last name as LUI RFC User. Then, click on the Logon Data tab.
     
     
  3. Now, enter the password, and set the User Type as C Communications Data.
     
     
  4. In the appeared screen, click the Roles tab to add the role created.
     
     
  5. Now, click the Profiles tab, as shown in the following image.
     
     
  6. Then, appears a window with the created profile 'LIQUIDUISERVER’, as shown in the image below.
     
     
  7. Now, double-click on the created profile, and verify the authorizations.
     
     
  8. Click back, and then click Save.
     
     
  9. Hence, the role LIQUIDUISERVER is successfully assigned to the user RFCSource.
     

Can't find the answers you're looking for?