Liquid UI - Documentation - 1.1 Overview

1.1 Overview


Liquid UI introduced the ability to automatically run SAP 'headless' with a Liquid UI bot without the necessity of users manually launching SAP GUI and entering data. This bot can be run either manually through a command prompt or by creating a scheduled task in the Windows Task Scheduler. To work with the bot, you will need to install the Liquid UI Web Server and launch the GuiXT4WebApp. Sometimes, this application is also referred to as the GWA or Liquid UI Web Application. The bot will automatically log into SAP and run your custom scripts without any user involvement. It also provides SAP users the ability to run tasks continuously without requiring user interactions. Furthermore, it can also provide administrators or managers with data even at odd hours when most personnel are not on-site.


Architecture

Liquid UI with Native Channel Architecture enables SAP customers to upcycle their current SAP ERP and S/4HANA infrastructure and are the most reliable and trusted SAP S/4HANA modernization platform. It leverages as the core of its digital transformation. The Liquid UI Platform is the industry’s only platform built on Native Channel Architecture and comprises three functional pillars: the Adaptable UI, Native Mobility, and Robotic Process Automation (RPA). To bring a consumer-grade UX to a variety of enterprise touchpoints, functional pillars will synergistically enhance the SAP GUI infrastructure and protocols. Additionally, the platform incorporates various enterprise features to boost workforce productivity at any ERP and S/4HANA touch point.

 

 


Easy Deployment

The Liquid UI bot solution is very easy to install and configure. The Liquid UI bot requires a windows-based operating system to run successfully in your system. Both Server and single-user client systems support the bot, however, it is intended to run as a scheduled operation from a server. The bot will function on any of the following windows-based operating systems. It does not require any additional RAM beyond the Microsoft system requirements and requires only 10MB of hard disk storage, without creating any custom scripts.

Learn more about how to Install a bot.

 

The following are examples of how our customers use the Liquid UI bot:

  • Checking stock and emailing the available material count to the managers.
  • Periodically uploading to SAP items like material details, purchase orders, quotations, and standard items that are queued in the database.
  • Periodically monitoring and sending email or native device notification alerts for low stock.
  • Searching and updating databases periodically to update statistics including data loads, stock details, and more.
  • Send native device notifications to Managers for reviewing blocked Sales Orders or Cycle Counts.
  • Reading data from *.csv files and updating SAP records accordingly.
  • Making Remote Function Calls (RFCs) to automate the process. If exists any exceptional scenarios like a sales order require special permission to process a purchase order or sales order, the bot captures the scenario and notifies the manager.
 

In standard SAP S/4HANA, ERP, and ECC installation, the automation functionalities mentioned above can only be accomplished through custom ABAP programs or remote function calls. It is not only cumbersome to implement but also complicates the process since the programmer must know which RFC is necessary and how to call that RFC. Bot eliminates these drawbacks and allows simplified ways to automate SAP tasks. Additionally, your users do not require any knowledge of RFCs - as the bot works at runtime through the Liquid UI engine. Furthermore, it also has the advantage of working on all SAP ERP transactions regardless of whether or not that transaction has an RFC available.


Workflow Management

Imagine you're in a situation where you need to automate the process of logging on to SAP and performing some work. You could programmatically do this without any user input, but in order for it to be effective, there must be no alternative route. For example, that work could be checking a server to see what stock is available and then sending an email out. You can check the data periodically, compare it, and then email SAP if you notice any low inventory levels. Until now, there has been no way to automate the logon session and run an SAP GUI session without one.

 

Until now there has been no way to automate a logon session; and run an SAP GUI session, headless. In other words, run a whole session without SAP GUI. Well, with the Liquid UI bot, you can.

Its mission: A wholly unattended, automated, scheduled, task-oriented job pusher, the complete FULL-TIME EQUIVALENT (bot), who works tirelessly on SAP.

Liquid UI bot workflow is a comprehensive measure of the upcoming tasks planned to allocate to the project. Liquid UI bot uses scripts to perform a given task automatically, such as periodically monitoring and sending an email or native device notification alerts for low stock to managers and users automatically from SAP. Mainly, the bot automates the manual and repetitive SAP business processes, specifically to simplify the SAP user task.

The program can be run either manually through a command prompt or by creating a scheduled task in the Windows Task Scheduler. It provides a programmatic way for users to log in to SAP (load balancing supported), and from that point on, a custom set of WS scripts will take over and drive the process.


Workflow Scenarios

Let us consider two use cases for a better understanding of “How the Liquid UI bot Works?”.

The first use case is uploading the changes that all the SAP users performed on a particular day. In this case, using the traditional approach, we would perform the following actions to retrieve the data required.

  • Create an ODBC connection to the database with Synactive WSODBC functionality.
  • Create an SQL query to retrieve the required data.
  • Create a function to log into SAP.
  • Add all the required operations in the elogon.sjs file.
  • Upload the data to perform the required action in the transaction.
  • Perform auto exit once you are done with uploading data.
 

Now let’s implement the same scenario using the Liquid UI bot.

  • Create a task by creating custom scripts in Liquid UI WS or by recording transactions with the Liquid UI Designer.
  • Upload scripts to the appropriate script repository.
  • Configures the bot to use these custom scripts and execute the designated workflow contained therein.
  • Creates the task in the Windows Task Scheduler to launch the bot.
  • At a specific time, the bot starts up automatically and establishes a connection to SAP.
  • Performs the specified task and uploads the data.
  • The bot will automatically log off from SAP.
 

The second use case is entering the user’s data for a specific transaction into an Excel spreadsheet. This operation can be done using the WS office or the WS engine built into the file reading/writing commands.

Let’s execute this transaction using the bot as follows.

  • Bot wakes up automatically
  • Reads the data
  • Uploads the data to the specific SAP transaction
 

The third use case is a simple exercise demonstrating how you can use SharedMemory and the autoexit variable to create an infinite loop of the SAP logon and logoff process without any user interaction. This exercise can be run either as a single logon and logoff, or it can be changed into an infinite loop by calling a variable stored in SharedMemory.

Learn more about How to use SharedMemory for a bot.

 

In the fourth example, we will use a bot to create a new notification in SAP. Learn more about Creating a Notification with the bot.

 

Either way, the Liquid UI bot could automate the process and perform the uploads regularly each night, whilst the users themselves were fast asleep.


Can't find the answers you're looking for?