Liquid UI - Documentation - 1.3 Bot Components

1.3 Bot Components


In the previous section, you’ve seen the Liquid UI bot workflow and here let’s look into the bot components.

SharedMemory API

Bot introduces a new API called 'SharedMemory', which enables two separate applications to communicate with each other and share data. This SharedMemory helps in designating a shared memory location in RAM, reading and writing data back and forth to that memory location or text file from multiple applications. Know about bot-specific information on the SharedMemory API at the Avatar.sjs file section.

Another important feature of this SharedMemory API is its ability to define and access variables from outside the bot. This feature requires a variable called autoexit to detect when the scripts end to provide graceful termination for both success and failures.

Features to demonstrate the SharedMemory API functionality:

Autoexit Variable

One useful SharedMemory API feature is the ability to define and access variables outside the bot and helps in detecting when scripts end and provides a graceful termination after both success and failures.

It is a boolean variable with two states - true and false. Here, the 'true' state is the default one that indicates graceful termination whereas the 'false' state will cause the script or process to freeze or get stuck in the event of a problem.

However, you can define your variables with either Boolean values as in this case or with actual data, which can then be read and used for various purposes, such as the dynamic use of the switchto command that we will also demonstrate later in this document.

Licensing

Bot requires a valid license both for the WS engine and for the Liquid UI Web Server in order to function. Please see the Licensing section for additional information about obtaining licenses.


Can't find the answers you're looking for?