Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Sabir Mohammad

Pages: 1 [2] 3 4
16
Purpose: To remove the applied license.
Steps:
1. Navigate to the connection list screen.
2. To the top corner, click on the three horizontal lines (Settings).
3. Click on the option "App Settings".
4(a). For IOS, click "Remove License".
4(b). For Android, long press on the license area and click on "Remove".

See attachments for further reference.

17
Purpose:
     This feature helps the user further validate the report by uploading their signature in key business scenarios as proof of authentication.
Example:
1. Navigate to any transaction which has SFO like IW24.
2. To the top right corner on the screen, one will see SFO - symbolically a paper clip, Hence Tap on it to select the option "Create Attachment".
3. Select the option "signature" from the pop-up list.
4. Draw the signature within the empty area and click on "Done".
5. Enter the file name for signature and click on "Done".
6. A success message will appear on the screen.

See attachments for further reference.

18
Purpose:
_page.exists: It is used to verify whether a given tab or page is actually present in a transaction.
_client: It is used to find the SAP client and output it to the console window.

LiquidUI Code:
    Below code demonstrates the usage of above system variables on VA01 transaction.
---------------------------- SAPMV45A.E4001.sjs -------------------------------
if(_page.exists("Sales")){           //verifying whether the sales tab exists
       set("F[Sold-to party]", "1460"); //Assigning the value to the field
}
println(" SAP system client is:" + _client); //Displaying output on console window

19
WS aka Web Scripts (Attended RPA for SAP) / Using "/ws[command]" at runtime
« on: November 30, 2017, 10:06:48 AM »
Purpose:
       Allowing the user to execute the ws command at runtime from the transaction field.
Syntax:
/ws[command]("argument")
   The 'command' part is replaced by an actual WS command like 'set' or 'del'.
   The 'argument' part is replaced by the screen control name.
Example:
If the user wants to set the 'Order Type' field to value 'OR' from the transaction field. He can follow these steps.
1. Navigate to 'VA01' transaction.
2. Enter /wsset("F[Order type]","OR") in the transaction field and execute.

See Attachments for further reference

20
WS aka Web Scripts (Attended RPA for SAP) / Variations of Tip Command
« on: November 23, 2017, 09:43:54 AM »
Purpose:
          Tip command can be used to add tips to various SAP native screen elements like Inputfield, Pushbutton, Groupbox, Checkbox, Radiobutton.
      This allows developer to further add information related to the screen element in the form of tooltip which inturn helps the enduser to understand the functionality of that screen element.

Syntax:
     tip("screen element code[screen element name]","adding tip");

Example:
    Pushbutton: tip("P[Class selection]","select the appropriate class");

Liquid UI Code:
    Below code demonstrates the variations of tip command on QM50 transaction.
---------------------------- RQMAAG10.E1000---------------------------
tip("F[Sel. prof.]","List of profiles to select from"); //Inputfield
tip("G[Notif. selection]","To selection notifications"); //Groupbox
tip("P[Class selection]","select the appropriate class"); //Pushbutton
tip("C[Notifications]","Evaluating notifications"); //Checkbox
tip("R[Day]","Summarizing notifications based on creation day"); //Radiobutton




21
Purpose:
       The option "uppercase" makes the inputfield value appear in upper case which enhances the readability of the entry made.
       Whereas the option "invisible" hides the value entered in the inputfield with special character *. This option is useful in scenarios where user wants to create an inputfield like password or a secret pin to hide the entry.

Below code demonstrates the use of "uppercase" & "invisible".
LiquidUI Code:
---------------------------- SAPLSMTR_NAVIGATION.E0100---------------------------
del("X[IMAGE_CONTAINER]");
inputfield([3,5],"Username",[3,20],{"name":"inptfld_1","size":14,"uppercase":true});
inputfield([4,5],"Password",[4,20],{"name":"inptfld_2","size":14,"invisible":true});

22
WS aka Web Scripts (Attended RPA for SAP) / Using "/ws_log" runtime command
« on: November 09, 2017, 10:04:06 AM »
Purpose:
      Turning WS logging on and off at runtime by providing the command in the transaction field in SAP.

Syntax to turn on the logs:
      "/ws_log=true" is the command used to create logs. Whenever this command is used a text file with extension .log will be saved by default in the following directory:

       "C:\Users\User_name\Liquid UI Log"

The file format will be as follows:
"WS_MMDDYY_HHMMSS_computerName_userName_.log"
Where  in MMDDYY,
            MM represents month
            DD represents date
            YY represents year
And in HHMMSS,
            HH represents hours
            MM represents minutes
            SS represents seconds

Syntax to turn off the logs:
        "/ws_log=false" is the command used to close the WS logs. Whenever this command is used the logs will be stopped recording in the log file created.
Note:
Whenever these commands are used to turn the WS logging on or off a message in the status bar will be shown with the location of the log file.

Refer the attachments for more information.

23
Purpose:
      To display the html file using viewhelp option of Image command.

Below code demonstrates the usage of viewhelp option to display the html file in Image command on VA01 Initial screen.
LiquidUI Code:
---------------------------- SAPMV45A.E0101.sjs -------------------------------
image([12,2], "test1.jpg" ,{"viewhelp":"liquidui.html", "viewhelp_width":35, "viewhelp_height":10, "viewhelp_position":[12,30]});

Following is the html code used to demonstrate the same.
HTML Code:
<html>
<head>
<title>LIQUID UI</title>
</head>
<body>
<ol>
<li>
Customizing SAP ERP

<li>
Liquid UI Products
</ol>
</body>
</html>

24
Purpose:
     Liquid UI Android allows the user to switch the "system message Icon" display between SAP and Liquid UI.

Steps:
1. Start Liquid UI Android and on the connection list screen, single tap the settings icon to the left top corner - symbolically three horizontal lines.
2. Select the option "App Settings".
3. Scroll down the Insider to select the option "System Message Icon".
4. Now choose any of the options as per the convenience.
5(a). Navigate to the transaction to see the changes taking effect.
5(b). The "System Message Icon" shows as below, if the option "Use LiquidUI Icons" is selected.

See attachments for more information.

25
WS aka Web Scripts (Attended RPA for SAP) / LiquidUI Columnsize Command
« on: October 12, 2017, 11:25:37 AM »
Purpose: This command can be used to resize and also to delete/hide the Native SAP Table Columns.

Syntax:
columnsize("[table_name,column_name]", value);
(Or)
columnsize("[table_name,column_number]", value);

Note: To hide/delete the column one needs to input the value as 0.

LiquidUI Code:
Below code demonstrates the usage of  columnsize command on VA01 transaction Overview screen.
---------------------------- SAPMV45A.E4001.sjs -------------------------------
//Resizing the column
columnsize("[All items,Material]",6);
columnsize("All items,2",6);  // Resizing Column using column number

//Deleting the column by assigning value:0
columnsize("[All items,Description]",0);

Note:
When there are Multiple Columns in the SAP Table with same column Name, then use column number instead of column name.
columnsize("All items,6",0); // Using the Column Number


See attachments for more information...

26
WS aka Web Scripts (Attended RPA for SAP) / _list System Variables
« on: October 10, 2017, 07:20:26 AM »
_listfirstvisiblecol:
      Specifies the position value of the first column of a list screen visible to the user.
__listlastvisiblecol:
      Specifies the position value of the last column of a list screen visible to the user.
_listtotalwidth:
      Specifies the actual width of the list screen.
_listdatawidth:
      Specifies the width of the listscreen visible to the user.

LiquidUI Code:
    Below code demonstrates the usage of above system variables on VKM1 transaction.
---------------------------- RVKRED01.E0120.sjs -------------------------------
//To display the position value of the first column visible
println("------First visible col is--------" +_listfirstvisiblecol);
//To display the position value of the last column visible
println("------Last visible col is--------" +__listlastvisiblecol);
//To display the actual width of the listscreen
println("------Total width of the list screen is--------" +_listtotalwidth);
//To display the width of the listscreen visible to the user
println("------Data Width of the list screen is---------" +_listdatawidth);

See the attachments for more information

27
Purpose:
      The "noinput" command makes the SAP screen element read-only restricting the user input. This command can be used with any SAP screen element that allows user input but cannot be used on user-defined fields.

Syntaxes:
noinput("F[field_name]"); // Makes a single inputfield read-only.
noinput("C[checkbox_name]"); //Makes a single checkbox read-only.
noinput("T[table_name]"); //Makes an entire table read-only.
noinput("[table_name,col_name]"); //Makes a specified column read-only using the column name.
noinput("[table_name,col_no]"); //Makes a specified column read-only using the column number.

Liquid UI Code:
Below code demonstrates the usage of noinput() command on ME22N transaction.
------------------------------SAPLMEGUI.E0014.sjs--------------------------
noinput("F[Currency]"); // making the inputfield "Currency" readonly
noinput("C[GR Message]"); // making the checkbox "GR Message" readonly
noinput("T[TABLE.2]"); // making the entire table readonly using the name of the second table - "TABLE.2"
noinput("[TABLE,PO Quantity]"); // making the column - "PO Quantity" readonly using column_name
noinput("[TABLE,11]");  //  making the column - "Net Price" readonly using column_no
noinput("F[Item]");  //making the dropdown - "Item" readonly



28

Purpose:
      Executing scripts from different directories by specifying the directory path in the SAPGUI command bar.  This will be useful when user wants to test different scripts written for a particular screen within a session, avoiding the need of stopping GuiXT WS to define script directories manually in the guixt.sjs file.

Syntax:
The following syntax can be given in the command bar.
/n[tcode]/dx=c:\\directoryname.
The script directory is specified by 'dx' where 'x' takes values of [1-4].

Example:
/nva01/d1=c:\\guixt\\scripts1
/nva01/d2=c:\\guixt\\scripts2
/nva01/d3=c:\\guixt\\scripts3
/nva01/d4=c:\\guixt\\scripts4

29
WS aka Web Scripts (Attended RPA for SAP) / system variable _liststring
« on: September 21, 2017, 12:18:45 PM »
Purpose:
       _liststring is used to read the cell value double clicked on a list screen, into a variable and to display it on the Cornelius window.

Below example explains the usage of _liststring on ME28 transaction second screen.

LiquidUI Code:
---------------------------- RM06EF00.E0120.sjs-------------------------------
//setting the _liststring value into a LiquidUI variable
set("V[z_ls_data]",_liststring);
//variable value will be displayed on the cornelius output
println("-------the value is-------"+z_ls_data);

30
Purpose:
       Using this option users can show or hide the user input history within the inputfields.

Example Steps:
Step 1: Open a session and Navigate to the transaction IW21 then enter the necessary value within the desired inputfield.
Step 2: A bubble with similar suggestions to choose from user input history will popup on the inputfield.
Step 3: Navigate to the App Settings on the IOS Device to Disable the user input history.
Step 4: Navigate back to the transaction and close the session for the changes to take effect.
Step 5: Open a session and navigate back to the transaction and enter the necessary value to see that the user input history is not shown.

Note: Any time the Enable/Disable settings are changed during the session, then that session should be closed and a new session should be opened for the changes to take effect.

Pages: 1 [2] 3 4