Liquid UI - Documentation - 6.06 columnsize()

6.06 columnsize()


Purpose

With columnsize(), you can define the size of a SAP table column.

This command sets the size of a given column in a table by specifying the actual size in pixels. The value must be set to less than the default size of the column as it is used primarily to restrict entry. The size cannot be set to a value greater than the column's original size. The columnsize command differs slightly from the columnwidth command described below although they are very similar in function. The major difference is that with the columnwidth command, the column size can be changed in a script with the 'size' option. However, once a size is set with columnsize, it cannot be changed in a script.

Note: columnsize() can only be used on native SAP table columns. It will not work on Liquid UI table columns.


Syntax

  • For Native SAP tables
    columnsize("Col_name", value);

    This syntax below is used when there are multiple tables on the screen.

    columnsize("table_name, column_name",size);


Options

The columnsize command does not take any options.


Example

To show the usage of columnsize() command, we will use an existing table from VA02 Create Standard Order: Overview section that shows scenario of usage of this command:

 


Script Details

SAPMV45A.E4001.sjs

columnsize("All items,Material",20);

Note: If the value is set to zero (0), the column itself will be deleted. This command works only with native SAP table columns.


Usage Details


Can't find the answers you're looking for?