Liquid UI - Documentation - 14 Conditional scripts

14 Conditional scripts


Beginner 3hr.

Customize SAP screens with various types of conditionalized scripts

Different ways to customize screens using conditional if statements
Message command with pop-up
Learn how to create a popup message to confirm an activity performed.
5 min
Edit and save text on same screen.
Learn how to edit and save the text in the textbox.

5 min
Assign values to screen elements
Learn how to assign values to various screen elements based on condition.

5 min
Scenario 4 - Creating a Notification
Learn how to save the notifications on the Create Notification Maintenance Request screen.

5 min
Get server name using _ashost variable
Learn how to acquire the SAP server name and customize the screen based on the SAP server.

5 min
Change your SAP GUI layout based on the client device
Learn how to change the layout of your SAP GUI based on the device used.

5 min
Toggle layout of an SAP screen
Learn how to toggle the layout of the SAP screen using Liquid UI design.

5 min
Get exception detail of a function module call
Learn how to display the exception detail of a function module call.

5 min
Display event performed using eventid option and _eventid system variable
Learn how to demonstrate the event performed on the screen.

5 min
Get the system ID or database name using _database
Learn how to use the system ID or the database name of an SAP system.

5 min
Get transaction name using _transaction
Learn how to retrieve the transaction name and customize the screen based on the transaction.

5 min
Validate time format, hh:mm:ss
Learn how to validate time format entered in an input field.

5 min
Learn how to change the layout of your SAP GUI based on the device used.
Learn how to access six different purchase order transactions on a single screen.

5 min
Creating a class to display sales order details
Learn how to display item details of a Change Sales Order overview screen

5 min
Validating fields
Learn how to validate data entered in the inputfields.

5 min
Purchase Order Screens
Learn how to access six different purchase order transactions on a single screen

5 min
Get login username and role using _client
Learn how to use User Catalog to Assign/Change the Directory 1 of the Scripts based on the group assignment for SAP User/Role.

5 min
Change readonly status dynamically
Learn how to change the read-only status of the elements on the Create, Change, and Display Maintenance Order screens.

5 min
Dynamic layout changing
Learn how to customize the layout of the screen dynamically.

5 min
Copy text to other screen elements.
Learn how to update the notification details of a notification dynamically using copytext.

5 min
Conversion of array data to grid data with to and fro navigation
Learn how to display data in a grid using array data.

5 min
Get hostname of the PC using _hostname
Learn how to return the client PC name or computer name using _hostname system variable.

5 min

 

Different ways to customize screens using the switch statements in the scripts
Sort table values based on column
Learn how to use the Insertion algorithm to sort items in a table.
5 min
Unpad Zeroes from String
Learn how to check the validity of user entered date format by retrieving date format from SU03 transaction and comparing with user entered value.

5 min
Padding a String
Learn how to remove zeroes from a string entered on SAP fields.

5 min
Convert date to required format
Learn how to add values before the value entered in the inputfield.

5 min
Validate date format and display message
Learn how to convert date specified into the required format.

5 min
Integrating Windows List View Control with SAPGUI
Learn how to check the validity of user entered date format by retrieving date format from SU03 transaction and comparing with user entered value.

5 min

 

Different ways to customize screens using the for loop statements in the scripts
Get first visible row and last visible row values from a listscreen
Learn how to read data from a screen containing a list.
5 min
Clear Liquid UI table
Learn how to clear the selection of selected rows in a table.

5 min
search_option function
Learn how to use search_option function to retrieve the order number from a message

5 min
Reorder table values to remove empty rows
Learn how to remove all the empty rows in a list and move the populated rows in Order.

5 min
Update multiple item fields based on the screen size
Learn how to convert user entered decimal format to SAP decimal format

5 min
Sort content in order
Learn how to sort values in the grid.

5 min
Display log file information as the status message
Learn how to display the information in log file which is produced during execution of the script files, as message in the status bar.

5 min

Can't find the answers you're looking for?