Liquid UI - Documentation - 8.01 enable()

8.01 enable()


Purpose

With enable(), you can execute script of another screen. This enables you to view modifications in another screen while executing a function in a screen.


Syntax

This enable command takes following syntax:

enable("executescreenscript");

Note: You need to place this command after onscreen command to execute the script of the particular screen.


Options

The enable command does not take any options.


Example

The following example demonstrates the usage of enable command in executing the paricular screen script while executing a function.

  1.  Navigate to SAP Easy Access screen and enter /3 or /15 in the command field and click enter.
  2. This will run the process that enables you to execute the script of another screen. Here, we are enabling the execution of the script for a pop-up window from the SAP Easy Access screen.
     
  3. You can view the changes done in the pop-up window after execution.

Note: /3 is the Fkey(F3) to perform back operation and /15 is the Fkey(shift+F3) to perform SAP logoff operation.


Script Details

SAPLSMTR_NAVIGATION.E0100.sjs

 onUIEvents['/3']={"fcode":"?","process":backtoHome};
 onUIEvents['/15']={"fcode":"?","process":backtoHome};

function backtoHome(){
   
   //Display Equipment : General Data
   onscreen 'SAPLSMTR_NAVIGATION.0100'
   clearscreen();
   enter('/o'); //Overview of Sessions Popup

   onscreen 'RSM04000_ALV.2000'
   enable("executescreenscript");
   
}

RSM04000_ALV_NEW.E2000.sjs

clearscreen();
   title("Exit Transaction?");
   text('P[Cancel]','@02@No');
   text('P[Continue]','@01@Yes');
   text([1,2],"@1A@Changes made would not be saved");
   text([2,6],"Do you want to exit?");
   windowsize([3,3,55,8]);

Can't find the answers you're looking for?