Liquid UI - Documentation - 10.09 Get Liquid UI Version, SAP GUI version, SAP GUI patch level details using _version, _sapgui_version, _sapgui_patch system variables.

10.09 Get Liquid UI Version, SAP GUI version, SAP GUI patch level details using _version, _sapgui_version, _sapgui_patch system variables.


Prerequisites


Purpose

You will learn how to use the system variables "_version", "_sapgui_version" and "_sapgui_patch" to find the version details of Liquid UI, SAP GUI, and Patchlevel. You can conditionalize the Liquid UI scripts as per the requirement. You can also use these details when reporting an issue to the help desk or before updating a new version.

  1. Delete all the screen elements
  2. Add OnUIEvents() to execute function
  3. Add z_luiSysVar() function

//Create this file inside your script folder for customizing SAP Easy Access screen SAPLSMTR_NAVIGATION.E0100.sjs
//Now let's start adding the content to the above file

  1. Delete the image container on the SAP Easy Access screen as shown below.
     
    //Deletes the screen elements on the SAP Easy Access screen. 
    clearscreen();
    

     
  2. Add an OnUIEvents command, to execute the z_luiSysVar process on performing enter operation.
    // Executes z_luiSysVar process on performing enter operation in new session
    onUIEvents["Enter"]= {'fcode':"/0",'process':z_luiSysVar};

     
  3. Add a function to display the "_version", "_sapgui_version" and "_sapgui_patch" details of an SAP system.
    // Creates a function to display version details of an SAP system on the cornelius window
    function z_luiSysVar() { println("Liquid UI Version: "+_version); println("SAPGui Version: "+_sapgui_version); println("SAPGui Patch Level: "+_sapgui_patch); }

     
  4. Click enter button on the SAP Easy Access screen as shown below to display the "_version", "_sapgui_version" and "_sapgui_patch" details of an SAP system in the console window.


     

Can't find the answers you're looking for?