Liquid UI - Documentation - 10.24 Get unique device token using _notificationID system variable

10.24 Get unique device token using _notificationID system variable


Prerequisites


Purpose

Learn how to get the unique device token values using _notificationID system variable to your Android and iOS devices through Liquid UI Server. The device token values are unique for a device and specifically used for push notification service. You can view different notification IDs for different devices.

Note: Beginning with the versions of the following Liquid UI products, you can access the _notificationID value for the notification feature.
 

Liquid UI Server:          Version 3.5.567.0 and above
Liquid UI on Android:   Version 2.0.33.0 and above
Liquid UI on iOS:           Version 2.0.26.0 and above


User Interface

//Create this file inside your script folder for customizing the SAP Easy Access screen: SAPLSMTR_NAVIGATION.E0100.sjs

//Now, let's start adding the Liquid UI script to the above file and save it.

  1. Logon to SAP and delete the image container using the del command on the SAP Easy Access screen, as shown below.
     
    // Deletes an image container on the easy access screen
    del("X[IMAGE_CONTAINER]");
     

     
  2. Add an input field with no label to display the notification ID of Android and iOS devices, as shown below.
     
     //Creates an input field with no label.
    inputfield([1,0], {"name":"z_notificationID", "size":180, "readonly":true, "nolabel":true});
     

     
  3. Add the following Liquid UI script code to this file and save it.
     
    set("V[z_notificationID]", _notificationID);
    println("=====>> _notificationID="+_notificationID+"<==");
    


SAP Process

    1. Connect your Android device to the Liquid UI Server to see the device token value displayed in the input field created on the SAP Easy Access screen, as shown in the following image
       
       
      Example of an Android device token:
      f5R8ErhYdBI:APA91bG1Le-6i3ArojW0jEEvfU3eZCKeenCCCHe_yn-0iJRKaLeQV3AWM60ds5DLMTdrAtMGhq7sy_f5Cq04TdyE7hA1DPIWSSZi9hZckMTR2DyaVvFMZDMajthyznHpb3INQgkGNgaN
       
    2. Similarly, connect your iOS device to Liquid UI Server to see the device token value displayed in the input field of the SAP Easy Access screen, as shown in the image below.
       
       
      Example of an iOS device token:
      3b1459128815b0f63109df1559d53e6d0757fc2d845f36018ae7021bb374b9c8
       
    3. You can also view the _notificationID values in the Cornelius window of the Liquid UI Server. The value of _notificationID will display "undefined" if it is connected from SAP GUI.
       
      Note: You can access _notificationID value only for Android and iOS devices, which can install Liquid UI applications.
       

Can't find the answers you're looking for?