Liquid UI - Documentation - 17.21 How to change title during screen automation?

17.21 How to change title during screen automation?


Prerequisites


Purpose

In this article, you will learn how to change the title of the standard SAP screen during the SAP Automation process. For instance, the long-running of a function can increase the processing time while automating multiple screens.

You can change the SAP screen title multiple times under the onscreen blocks. Here, we are using the title command to display a suitable title on the screens while executing the defined process. To achieve this, you have to define a variable or string, or both. For better understanding, we’ll guide you through the following steps:

  1. Delete unnecessary screen elements using the clearscreen command
  2. Add a pushbutton to call the function
  3. Add a function to change the screen title


User Interface

//Create the file SAPLSMTR_NAVIGATION.E0100.sjs inside your script folder for customizing SAP Easy Access Screen.

//Now, let's add the Liquid UI script to the above file and save it.


Customization

  1. Logon into SAP and clear the unnecessary screen elements on the SAP Easy Access using clearscreen().
     
    //Deletes unnecessary screen elements on the SAP Easy Access screen 
    clearscreen();
    
     
     
  2. Add a toolbar pushbutton labeled Change Title that calls the user-friendly function called newtitle, and displays a notification on click.
     
    // Creates a pushbutton with the label Change Title to call a function when clicked. 
    pushbutton([TOOLBAR],"Change Title",{"process":newtitle});
     
     
  3. Now, add a function named newtitle to indicate that the system is carrying out a substantial amount of tasks, and display a notification as Reading Notification Data. Please Wait…, on the SAP Easy Access screen.
     
    //Adds a function to display the notification while executing the process 
    function newtitle() {
    onscreen 'SAPLSMTR_NAVIGATION.0100'
      title("Reading Notification Data.. Please Wait...");
    enter("/niw23"); 
    onscreen 'SAPLIQS0.0100'
      title("Navigation to Notification Screen.. Please Wait...");
    set('F[Notification]','[10001291]');
    enter();
    }

 

SAP Process

  1. Refresh the SAP screen and, click the Change title push button to navigate to the Display Notification screen., While executing the process, it displays the notification "Navigation to Notification Screen.. Please Wait”, as shown below.
     
      
  2. After the notification screen, a window appears with the new notification Display PM Notification: PR Maintenance. Request, as shown below:
     
     

Can't find the answers you're looking for?