Liquid UI - Documentation - 6.16 localvaluehlp()

6.16 localvaluehlp()


Purpose

With localvaluehelp(), the users can dynamically access local value help on entry fields. Localvaluehelp is supported on SAP standard fields, your own inputfields, and table columns. You perform right-click on the field to invoke a popup with possible inputsets. This command will function both on Liquid UI and native SAP fields.


Syntax

localvaluehelp("[screen_element]",{"option":value…});


Properties

  • screen_element - Element code and name.
Note: The localvalue help command can be only used with inputfields.

 

To enable localvalue help, the following entries must be entered in the guixt.sjs configuration file:

historyonrightbutton = true;
domains = "directory"

You can also store your localvaluehelp in domain files along with your script files in the SAP Web Repository (SAPWR). When you use SAPWR to store your localvaluehelp files, the 'directory' and 'domains' entries in your guixt.sjs file will appear very similar to the following example.

directory1 = "SAPWR:Z_GUIXT1";
historyonrightbutton = true;
domains = "SAPWR:Z_GUIXT1";

In guixt.sjs file, you can specify history visible for only Liquid UI fields, not for native SAP fields.

historyononlyguixt = true;

If the 'historyononlyguixt' entry is not present, both native SAP fields and Liquid UI created fields will have history enabled as long as the 'historyonrightbutton' parameter is present.

The 'historyonrightbutton' parameter enables the domain list box to display when the user right click. The 'domains' parameter specifies what history will be searched. The history will show all previously entered values, if an inputfield is not provided with a domain file. The directory path can be any of the following formats:

Local directories

To access localvaluehelp from a file present in a directory on your local machine:

C:\\directoryName
Network shares

To access localvaluehelp from a file present in a shared directory on the network:

\\\\network\\directory
Web shares

To access localvaluehelp from a file from a shared directory on the web:

http://directoryName
SAP Web Repositories

To access localvaluehelp from a file from the SAP Web Repository (SAPWR):

sapwr:z_directoryName
Note: Use the file() to give the file an alias if it exceeds the 30-character limitation on SAPWR file names.


Available Options

You can use the following options with the localvaluehelp:

"domain":".."

"domain":"domain_name" - Specifies the domain from which the localvaluehelp will be called.


Options Detail

domain

  1. This option can be used to specify the domain from which the localvaluehelp will be called. The domain is specified in the domains directory path, similar to the entry as in guixt.sjs file and will be the source from when the localvaluehelp is obtained.

  2. localvaluehelp("F[Material]",{"domain":"MATR"});
  3. As per the code, Material field will display material values on right click.

In addition to the above option, there is a procedure that is associated with localvaluehelp:

domain inputsets

  1. For localvaluehelp, you must create files that contains the inputsets that will display when a user trigger the field localvaluehelp. Fields will only display localvaluehelp if a domain is mapped to it as described in the previous section. The file that contains the inputsets must be named in the following format:

    dom.<languageKey>.<domainName>.txt			
  2. If there is no domain mapped to the field, then instead of the ' dom.<languageKey>.<domainName>.txt ' file, a different file will be read. This alternate file is usually named in the following format:

     dom.TEXT.<language code>.txt			
  3. The inputsets will be stored inside this alternate file. If no domain name is specified, then the domains will be read from this file.


Example

The following example will demonstrate the usage of localvaluehelp on a Liquid UI inputfield.


Script

localvaluehelp("F[Material]",{"domain":"MATR"});

Script Details


Tips and Tricks


Can't find the answers you're looking for?