Liquid UI - Documentation - 6.30 tab()

6.30 tab()



Purpose

You will learn how to use the tab command to move the cursor between fields on the SAP screen.

With tab(), you can navigate to the required input fields present on the SAP screen. For instance, while entering the values in the input fields in SAP, you can change focus from one input field to the required field automatically using the tab command, which saves navigation time.


Syntax

tab("[From-Screen-Field]","[To-Screen-Field]");


Options

The tab command does not take any options.


Properties

  • From-Screen-Field, To-Screen-Field - To set focus to a specified field from a given field.


Example

In the following example, we will use the tab command to move the cursor from one field to another in the Create Standard Order: Overview screen.


Customization

Create the file SAPMV45A.E4001.sjs inside your script folder for customizing the Create Standard Order: Overview screen using the tab command.
//Now, let's start adding the Liquid UI script to the above file and save it.

  1. Log into SAP, and navigate to the Create Sales Order: Initial Screen.
     
     
  2. On the appeared screen, input Order Type as OR, and then press enter. Now, you will be navigated to the Create Standard Order: Overview screen, as shown in the following image.
     
     
  3. Now, let’s use the tab command to navigate the cursor between respective fields. To move the cursor between PO date and Deliver.Plant, set the cursor focus on the PO date field, and then click inside the PO date input field. Now, pressing the Tab key on the keyboard will move the cursor to the Deliver.Plant input field.
     
     tab("F[PO date]","F[Delivery.Plant]");
     
     
  4. To move the cursor between Deliver.Plant and Payment card, set the cursor focus on the Deliver.Plant field, and then click inside the Deliver.Plant input field. Now, pressing the Tab key on the keyboard will move the cursor to the Payment card input field, as shown in the image below.
     
     tab("F[Deliver.Plant]","F[Payment card]");
     
     
  5. Similarly, to move the cursor between the Payment card and the All Items Table Item column First row, set the cursor focus on the Payment card field, and then click inside the Payment card input field. Now, press the Tab key on the keyboard to move the cursor to the All Items Table Item column First row input field.
     
     tab("F[Payment card]","F[All Items Table Item column First row]");
     
     

Can't find the answers you're looking for?